Le réseau francophone des utilisateurs du logiciel Clickteam Fusion

Messagerie
  • conceptgame
    Est-ce que la recherche fonctionne encore?
    conceptgame - 01/07/2020 18:49:39
  • Xenon3K
    Apparemment non je viens de tester :/
    Xenon3K - 01/07/2020 21:26:31
  • Xenon3K
    En faite j'ai revus presque tout mon code et certaines choses que j'ai oublié de tester
    Xenon3K - 01/07/2020 21:27:09
  • Xenon3K
    C'est ok pour la recherche
    Xenon3K - 02/07/2020 10:33:39

Bugs inconnu

Tryton
33 messages
Fusion 2.5 Dev
Fusion 2.5+
lundi 22 juin 2020 11:59

Bonjour à tous,
Gros soucis sur mon projet actuel, j'ai affaire un des crachs sur une scène sans raison apparente (alors que tout allé bien avant)
Je ne sais pas si c'est lier mais depuis ces crachs j'ai un objet décor rapide qui se place tout seul en X=0 Y=0 et qui ne disparaît pas de la liste d'objet quand je le supprime (j'ai bien vérifier, il n'y en a pas une copie sur la scène et il n'est pas global)

Un grand merci à celui qui trouverai une solution :O

Patrice
2728 messages
Fusion 2.5 Dev Fusion 2.5
Firefly Exporteur UWP Exporteur iOS Exporteur Android Exporteur HTML5 Fusion 2.5+
lundi 22 juin 2020 12:29

Il faut pouvoir regarder ton mfa. Tu peux isoler le bug ?

Tryton
33 messages
Fusion 2.5 Dev
Fusion 2.5+
lundi 22 juin 2020 12:37

J'ai désactivé différentes partie du code pour voir ce qui pourrai le provoquer, mais en vain.
Maintenant je n'ai plus les crachs mais toujours le problème du décor rapide.
(C'est frustrant de ne plus avoir un soucis sans savoir pourquoi :p)
Je peux te passer le *.mfa si tu veux jeter un œil :)

Patrice
2728 messages
Fusion 2.5 Dev Fusion 2.5
Firefly Exporteur UWP Exporteur iOS Exporteur Android Exporteur HTML5 Fusion 2.5+
lundi 22 juin 2020 12:45

oui je veux bien

Tryton
33 messages
Fusion 2.5 Dev
Fusion 2.5+
lundi 22 juin 2020 14:28

Le décor rapide en question est dans la scène MENU et s'appelle FOND MAUDIT:

https://www.transfernow.net/MwUUQa0062020

Désolé d'avance, tu va trouver le code un peu bordélique^^
Merci d'avance si tu trouve une solution :)

Patrice
2728 messages
Fusion 2.5 Dev Fusion 2.5
Firefly Exporteur UWP Exporteur iOS Exporteur Android Exporteur HTML5 Fusion 2.5+
lundi 22 juin 2020 14:43

Je pense qu'il faut que tu règles ça :


Tryton
33 messages
Fusion 2.5 Dev
Fusion 2.5+
lundi 22 juin 2020 14:58

Toujours le même soucis :/
(et les crachs sont toujours là finalement :( )

Patrice
2728 messages
Fusion 2.5 Dev Fusion 2.5
Firefly Exporteur UWP Exporteur iOS Exporteur Android Exporteur HTML5 Fusion 2.5+
lundi 22 juin 2020 15:06

Je n'ai aucun crash... Ton code est trop complexe. Il te faut isoler le crash pour le régler


Tryton
33 messages
Fusion 2.5 Dev
Fusion 2.5+
lundi 22 juin 2020 15:09

Mince :/ j'vais essayer d'arranger un peu tout ça pour trouver la cause !
Et pour le fond qui se place en 0/0, une idée ?

conceptgame
400 messages
Fusion 2.5 Dev
Fusion 2.5+ Firefly Exporteur iOS Exporteur Android
lundi 22 juin 2020 16:17

J'arrive à reproduire le crash. Si Patrice n'a pas trouvé avant, je regarde ça ce soir.

Tryton
33 messages
Fusion 2.5 Dev
Fusion 2.5+
lundi 22 juin 2020 16:22

Merci beaucoup à tout les deux :) Je tente de corriger ça de mon côté, je vous tiens au courant !

EDIT: Le fond que je n'arrive pas à supprimer est visible dans mes évenements.

fredetmumu
1046 messages

lundi 22 juin 2020 19:33

tu selectionnes tout ce qui est sur la scene, copié / collé dans une nouvelle scene

tu selectionnes tout le code , copié collé dans la nouvelle scene que tu viens de créer

tu fait bien attention a ce que 'fond maudit" ne soit pas sur la scene


Emmanuel
2096 messages
Fusion 2.5 Dev Fusion 2.5
Firefly Exporteur UWP Exporteur iOS Exporteur Android Exporteur HTML5 Fusion 2.5+
mardi 23 juin 2020 10:46

Bonjour dans les propriété du fond maudit option mémoire la case global et coche.

conceptgame
400 messages
Fusion 2.5 Dev
Fusion 2.5+ Firefly Exporteur iOS Exporteur Android
mardi 23 juin 2020 12:32

Bien joué Emmanuel!  C'est sûrement ça le problème.


Tryton
33 messages
Fusion 2.5 Dev
Fusion 2.5+
samedi 27 juin 2020 08:04

Il n'était pas en objet global mais j'ai trouvé la cause ce matin !
En copiant collant mes événements dans une nouvelle scène j'ai retrouver le même problème...
J'ai donc copier mes groupes d’événements un à un pour diagnostiquer le soucis, et j'ai découvert que le fond avait remplacer un actif dans une ligne ! (bug ou fausse manip' de ma part)


Merci à ce qui on donné de leur temps :)

Utilisateurs en ligne

Derniers messages